当前位置: IT大杂烩 > Ubuntu  > ubuntu14.04 安装svn插件

ubuntu14.04 安装svn插件

www.someabcd.com  网友分享于:Jun 8, 2018 6:02:52 PM

标签:android   ubuntu   svn   incompatible javahl   

转载请注明转自:http://write.blog.csdn.net/postedit


eclipse svn的插件无法使用,很是纠结。后来发现是安装版本兼容行的问题。

默认安装svn  默认版本是1.8.x
.javaHL library  ubuntu下默认的是1.6x的版本
eclipse svn插件 subversion 选择了1.8的。

在启动eclipse svn插件时   会遇到如下问题:
org.apache.subversion.javahl.clientexception:svn
Incompatible JavaHL library loaded. 1.7.x or later required.  

现解决,总结如下:

总的来说要安装三个
1.svn
2.eclipse svn插件 subversion
3.javaHL library

这是由于安装的svn, subversion ,javaHL library 不匹配导致
我安装的是   subversion1.8.x  svn1.79   javaHL library1.7.x   .

当然可以使用其他的版本安装,只要匹配。具体如下表:

bubuko.com,布布扣

http://subclipse.tigris.org/wiki/JavaHL


一。下载javaHL library

https://www.open.collab.net/cn/downloads/subversion/thankyou.html?_=d


CollabNetSubversion-client-1.7.18-1.x86_64.rpm


安装
sudo apt-get install fakeroot alien
fakeroot alien CollabNetSubversion-client-1.7.18-1.x86_64.rpm
sudo dpkg -i collabnetsubversion-client_1.7.18-2_amd64.deb
 sudo find / -name libsvnjavahl-1.so

二。安装svn

可以参考

KUbuntu/Ubuntu 14.04(降级)安装SVN 1.7

http://www.linuxdiyf.com/linux/2507.html

三。eclipse svn插件 subversion
可以参考

http://liujianqiao398.blog.163.com/blog/static/181827257201331194610634/


要注意下载对应的版本。




四。修改eclipse.ini

 -vmargs  【在此行下添加】
  -Djava.library.path=/usr/share/java/
  -Djava.library.path=/opt/CollabNet_Subversion/lib/  【注意 这个路径是find / -name libsvnjavahl-1.so的路径】
重启eclipse即可使用



ubuntu14.04 安装svn插件

标签:android   ubuntu   svn   incompatible javahl   

发布此文章仅为传递网友分享,不代表本站观点,若侵权请联系我们删除,本站将不对此承担任何责任。
Copyright ©2018  IT大杂烩  版权所有  京ICP备11030978号-1 网站地图