当前位置: IT大杂烩 > Ubuntu  > cisco1941 pppoe拨号上网client端配置

cisco1941 pppoe拨号上网client端配置

www.someabcd.com  网友分享于:Jun 8, 2018 5:50:49 PM

标签:server   路由器   接口   address   

近期公司新购进一台cisco  1941路由器用于网络升级,因专线未布置到位,暂时用于pppoe拨号上网,因设备有限,故Router洪当三个角色:拨号上网,DHCP服务器,DNS服务器,主要配置如下(G0/0 端口为外网端口,G0/1端口为内网端口):

拓扑很简单:Router ——Switch——client PC

配置主要分为以下几个方面:

1.配置内部接口G0/1

interface GigabitEthernet0/1

ip address 192.168.0.1 255.255.255.0            //设置接口内部IP地址

ip nat inside    //确认inside 接口

no shutdown                         //开启端口

2.配置DHCP服务

ip dhcp excluded-address 192.168.0.1      //设置保留不分配内部地址

ip dhcp pool client              //配置DHCP地址池client 

network 192.168.0.0 255.255.255.0       

default-router 192.168.0.1             //配置客户端PC获取路由

dns-server 192.168.0.1          //配置内部网络DNS

3.配置DNS服务

ip dns server          //启用Router路由功能 

ip domain-lookup    

ip name-server 221.228.255.1  218.2.135.1     //指定首选和备用DNS(各地有差异,请选择速度较快的) 

4.配置外部接口G0/0

interface GigabitEthernet0/0

pppoe enable group global        //开启外部接口pppoe功能,允许接口运行ppoe

pppoe-client dial-pool-number 2     //将以太网接口的pppoe拨号客户端加入拨号地址池2,即需要完成物理接口和逻辑地址池dial-pool-number 2之间的绑定

5.配置逻辑接口

interface Dialer1

ip address negotiated      //与Adsl服务商动态协商获取IP地址

ip mtu 1492      //定义帧数,因为PPP封装的原因,ip mtu要做相应调整

ip nat outside    //确认outside接口

encapsulation ppp   //封装ppp协议

ip tcp adjust-mss 1452   

dialer pool 2   //该接口使用拨号地址池2进行拨号

ppp authentication chap callin      //将认证模式设置为chap

ppp chap hostname XXX       //设置chap用户名

ppp chap password XXX    //设置chap密码

ppp pap sent-username XXX password  XXX    //拨号使用pap或者chap需依据服务商配置

ppp ipcp dns request       //动态获取dns

 

6.配置NAT服务

access-list 1 permit 192.168.0.0 0.0.0.255

 

ip nat inside source list 1 interface Dialer1 overload

 

7.配置Router

 ip route 0.0.0.0 0.0.0.0 Dialer1

 

PS:

1.cisco对于pppoe的设置采用的是BBA-group,而不是VPDN-group
所以没有办法在vpdn enable下面启用protocol pppoe
2.对于cisco设备客户端而言也就不需要去设置vpdn enable,即不需要配置VPDN服务

3.排错命令:debug pppoe events

cisco1941 pppoe拨号上网client端配置

标签:server   路由器   接口   address   

发布此文章仅为传递网友分享,不代表本站观点,若侵权请联系我们删除,本站将不对此承担任何责任。
Copyright ©2018  IT大杂烩  版权所有  京ICP备11030978号-1 网站地图