当前位置: IT大杂烩 > Ubuntu  > 在eclipse4.4 上安装反编译工具jd-eclipse

在eclipse4.4 上安装反编译工具jd-eclipse

www.someabcd.com  网友分享于:Jun 8, 2018 6:04:08 PM

标签:blog   http   io   os   ar   java   for   sp   文件   

一直用反编译的工具jd-gui 感觉还行。今天想配置下eclipse 的组件 -jd-eclipse工具


你可以在在网上搜索 "jdeclipse_update_site "   下载  java decompiler的eclipse插件

 

第一种方式:通过覆盖,或者eclipse>>help>>Install New Software来引入插件

第二种方式

 用link文件的方式

 把下载下来的eclipse插件解压

放在eclipse目录下新建的myPlugin比如:D:\Program Files\eclipse\myPlugin\jd-eclipse

在eclipse/dropins 目录新建个links文件夹,

在里面新建个文件jdclipse.link,文件名无所谓,只要后缀是.link

然后打开文件,写上path=D:\\Program Files\\eclipse\\myPlugin\\jd-eclipse   这个jd-eclipse就是你jd相对于eclipse根目录的目录

保存就OK了

 重启eclipse

随便点开一个class文件

 

可能会报一个错:

······ \eclipse-jee-luna-SR1-win32-x86_64\eclipse\configuration\org.eclipse.osgi\866\0\.cp\lib\linux\x86\libjd-eclipse.so: Can‘t load this .dll (machine code=0x101) on a IA 32-bit platform

 出这个错的时候,你需要去你下载的压缩包里找到

jd.ide.eclipse.win32.x86_0.1.3.jar 或者  jd.ide.eclipse.win32.x86_64_0.1.3 .jar  根据电脑是64位还是32位的去选择

解压他,在lib/win32/x86下复制jd-eclipse.dll文件

拷贝到\eclipse-jee-luna-SR1-win32-x86_64\eclipse\configuration\org.eclipse.osgi\866\0\.cp\lib\linux\x86\目录下,将jd-eclipse.dll重命名为libjd-eclipse.so将原来的覆盖掉

 重启eclipse,你就可以看到反编译好的class文件了

 

参考

http://tankmarshal.iteye.com/blog/1623373

http://aniyo.iteye.com/blog/1336622

http://www.cnblogs.com/bluesky4485/archive/2011/12/08/2280429.html

在eclipse4.4 上安装反编译工具jd-eclipse

标签:blog   http   io   os   ar   java   for   sp   文件   

发布此文章仅为传递网友分享,不代表本站观点,若侵权请联系我们删除,本站将不对此承担任何责任。
Copyright ©2018  IT大杂烩  版权所有  京ICP备11030978号-1 网站地图